A Unified Communication Blog
Get Adobe Flash player

Yesterday I was called to a customer because the customers brand new test environment for Exchange was falling in the setup of the Exchange 2007 SP1 CCR cluster on Windows 2008.

The pre checks works fine and the installation seems to run fine, but at the end of the setup where ithe setup creates the actual Cluster it fails with these errors:

[03-03-2009 12:56:24] [2] [WARNING] Object EXCH01 has been corrupted and it is in an inconsistent state. The following validation errors have occurred:
[03-03-2009 12:56:24] [2] [WARNING] Cannot calculate value of property “AdminDisplayVersion”: “SerialNumber property is not present.”.
[03-03-2009 12:56:24] [2] Ending processing.

And also

[03-03-2009 12:57:04] [2] Actual arguments passed to create EVS do not match existing server object in AD
[03-03-2009 12:57:04] [2] ScSetupExchangeVirtualServer (f:8.01.0240sourcesdevadminsrcudogexsetdataexsetds.cxx:2013)
Error code 0XC103FD2C (64812): One or more of these parameters: Administrative Group, Routing Group, Administrative Group containing Routing Group, Install path, and Data path did not match the existing Active Directory object. Please use Exchange System Manager to retrieve the correct parameters for this operation.
[03-03-2009 12:57:04] [2] Leaving ScSetupExchangeVirtualServer
[03-03-2009 12:57:04] [2] [ERROR] Unexpected Error
[03-03-2009 12:57:04] [2] [ERROR] Error of unknown type occurred while performing exsetdata operation; the original error code was 0xc103fd2c.
[03-03-2009 12:57:04] [2] Ending processing.
[03-03-2009 12:57:04] [1] The following 1 error(s) occurred during task execution:
[03-03-2009 12:57:04] [1] 0. ErrorRecord: Error of unknown type occurred while performing exsetdata operation; the original error code was 0xc103fd2c.
[03-03-2009 12:57:04] [1] 0. ErrorRecord: Microsoft.Exchange.Management.Tasks.ExsetdataUnknownException: Error of unknown type occurred while performing exsetdata operation; the original error code was 0xc103fd2c.
[03-03-2009 12:57:04] [1] [ERROR] Error of unknown type occurred while performing exsetdata operation; the original error code was 0xc103fd2c.
[03-03-2009 12:57:04] [1] Setup is halting task execution because of one or more errors in a critical task.
[03-03-2009 12:57:04] [1] Finished executing component tasks.
[03-03-2009 12:57:04] [1] Ending processing.

The setup was made in HyperV so I deployed two new servers from a template (clone with sysprep), and it ended up with the same error.
First after I made two completely fresh installations of Windows 2008 it worked.

I’m not sure what is causing the problem, but in the templates I used first, dot.framework 3.5 was installed (which I don’t normally have on my CCR clusters). In the new installation framework 3.5 wasn’t installed.

If you have any idea what was wrong in the first installations I would appreciate your comments.

Regards,
Joachim

One Response to Exchange Setup Error 0xc103fd2c

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Search

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 72 other subscribers

Follow me on Twitter