A Unified Communication Blog
Get Adobe Flash player

If you are running Exchange 2007 SP3 and needs the latest update for Exchange 2007 or want to update to Exchange 2013 then you will need this update.

For Coexistence with Exchange 2013 you will also need CU1 for Exchange 2013.

 

Readme

Download

 

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Search

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 70 other subscribers

Follow me on Twitter